Stop working after no change. #217
Unanswered
joaogbcravo
asked this question in
Q&A
Replies: 1 comment 5 replies
|
This usually happens under resource stress: the operator gets bogged down (e.g., when it re-renders the whole dataplane config periodically) and fails CDS pings. Increase the CPU limit: this makes sure the operator will not run out of CPU even under load spikes. You can also play with throttling datplane updates, e.g., setting |
5 replies
Sign up for free
to join this conversation on GitHub.
Already have an account?
Sign in to comment

Uh oh!
There was an error while loading. Please reload this page.
Hello!
Not sure this is a bug or just misconfiguration, therefore I open a discussion.
I have stunner-gateway-operator deployed using helm chart version 1.1.0.
Everything works, and suddenly, after some days, maybe weeks, livekit streaming doesn't work anymore.
On the stunner gateway I see
On the operator
I manage to understand that, if I restart the operator, then the gateway is restarted as well, and everything starts working.
AI suggests it can be some network blip and suggested me that I should increase the replicas of the operator (before was just 1 - I did that, not sure if it will fix the problem.
Any pointers of the root cause?
All reactions